  Premiere Tutorial Script 

Hello, everyone! My name is Marisa Wetterskog, and I am a Coordinator for the Program Development, Education, and Outreach team at the Office of Research and Innovation. 

Introduction

In this tutorial, we will be talking about Premiere. If you haven’t seen the previous tutorials, I highly recommend you watch those first to give you more context to Premiere and why we use it. This tutorial is going to be pretty heavy in details, and will therefore be on the longer side. I encourage you to still watch the whole thing, and then come back to specific parts when you need a refresher. Currently, I am the only team member that knows Premiere, so it’s extra full with details to make sure that you can handle this after I depart the team. There’s much more to learn about Premiere than this, but to keep the tutorial from being too overwhelming and long, I just included the basics of what you need to know in your work as a Student Assistant.

So, what is Premiere? Premiere is a program that lets you edit and put together videos. However, it is pretty overwhelming to learn at first, and it does have a few problems that I have experienced fairly frequently but have figured out some easy fixes. I will also go into how we use Premiere in our team/office. Additionally and as you have seen in the previous tutorials, I have a program on which will be in the bottom right corner, that will show you what buttons I am pressing.

So, you downloaded Premiere, and you’re super excited to start. You open it up, and oh my goodness, where do you even begin? There are so many panels, and it’s super confusing. So, without further ado, let’s get started with a tour! 

Tour

The first screen you see when you open up Premiere is the Home screen. All this is showing you is learning opportunities, recent files, and options to either open an old project or create a new one. For now, I'm going to click new project. Name it what you want and click the project location dropdown. Then click choose location to pick the folder that you need to save it in. I’m just gonna hit downloads. Just ‘cuz. Then click select folder, and then click create.

Your workspace probably looks something like this: The typical buttons are at the top: Minimize, Expand, and Close, with the usual menu options here. So below that, if you click on workspaces, you can see more workspaces here. We typically use the Effects Workspace the most, so I’m going to keep it on that. The Learning workspace would probably also be a good resource for you as well.

Let’s look at the panels now. On the bottom left one, you may have noticed it already hints as to what it does. “Import media to start.” This is where you import your videos, gifs, sound, pictures, any type of media that you need edited. Think of it like a library of connections for your project. (I will explain this more later in this video, and I also explained it in the InDesign tutorial.) Once you do that, you can drag your media into the section next to it, the Timeline. 

As the name implies, the Timeline shows you your line of media in respect to time. It’s a really effortless, visual way to see how all of your media works and fits together. 

The section above is called Program. Right now, it’s telling me that there are no sequences. That’s because I haven’t dropped anything into my Project’s media box and therefore haven’t put anything into the Timeline for Premiere to have a sequence to show in the Program panel. What your video project looks like so far will be visible here. Right now, the buttons and such are grayed out right here since we haven’t added anything yet so there’s nothing to play or interact with.

Last but not least, this is the Effect Controls group panel. The default that it will be on is probably the Source. I typically just move it over to the Event Controls’ group tab. There are obviously some other tabs in this panel group, which you can explore later, but the main thing you’ll probably use the most is the Effect Controls tab, which is useful for positioning and other features (that I’ll explain later). 


How to Fix Your Workspace

Before we move on, I’ll address a really easy thing to mess up (and to fix), which is your Premiere workspace. When you’re working quickly or maybe you just do it by accident – you drag something, click on something, close something, all the something’s, and then suddenly everything looks different, and you can't find anything and don’t know how to put it back to how you’re used to. Don't panic. Everyone has done this at least once, and if they say they haven't, they are liARS (or maybe they just don’t remember). 

So, how do we fix this? You can move windows like this by dragging it around. If it turns blue, that means you can add or move the thing you're dragging in there. As you can see here, if I drag it to the side, that’ll make it be on the side. If I drag it to this center box, that’ll make it be a tab in this panel box. A lot of panels will completely change their dimensions to fill the blue space, which makes it look really weird and kind of difficult to recognize. So, for example, if I drag the toolbox here, it doesn’t really look like what we recognize as the toolbox bar. And then, ya know, if I accidentally click on a[nother] tab, all that’s indicating to me that there’s a toolbox is this, so it would be kinda hard for me to find if I had to close out of Premiere and reopen it later in the week or something, I would probably not remember that tools is right here. 

So for the most part, you can just move them back like this, and you can adjust the dimensions, move it around, so on and so forth. You can also reorder the tabs that you want. You can even close the panel or close other panels in the group.

And as we discussed earlier, here you can change your workspace. So again, I usually have mine be on Effects or Editing (which is basically the same as Effects, just without the Effects Menu on the side). I think the default workspace is either Effects or Learning; I can’t remember.

Sometimes, no matter what you manually do, the workspace still looks so out of whack that you’re not sure how to fix it. Go to Window > Workspaces, and then hit Reset to Saved Layout. There are some other options, like if you really like how you formatted your workspace, you can save it here. You can also save changes (if it’s not on the default). I’m working on the Default, so it won’t let me save the changes. But for now, I’m going to click Reset. Or simply press Alt/Option + Shift + 0. And there you have it, Premiere will automatically reset your workspace. You can also go here in the workspaces menu where I already showed you and hit reset to saved layout. It’s just another easy way to do it.

General Overlook

Now that the tour’s over, I’m going to drop a video of a past event in here to show you what it’ll look like when there’s actually media imported inside. Feel free to grab a past event’s video just to practice. You can always edit it in the Downloads folder so you don’t have to worry about ruining something that is already done. This might take a few minutes, depending on how long your media is, so we will come back when it’s done and ready for us.

Okay, so as you can see, in this event, this one is already done, as there’s already a Premiere document. Plus, there’s an edited version that has already been exported, but for the most part, the Event Lead will put in the raw, original recording that they downloaded from Teams and they saved it into here for you to edit. So I’m just going to use this video and you just drag it in. This might take a few minutes, depending on how long your media is, so we will come back when it’s done and ready for us.

Now that we’ve got the video into the library of connections, let’s drag the video into the timeline. Again, this might also take a little bit, depending on how long your video is.  

I’m going to use the default workspace since it’s what everyone sees until they change it, but feel free to customize your workspace to your liking.

Program Section
The program section, like I briefly touched over before, is now significantly more open since we actually have a video imported. You can see your video here. It’ll play as you scroll through or let it play naturally. This blue time stamp is where your cursor currently is, so if I move said cursor, you’ll see the time stamp will also update. This other time stamp is how long the video is, which I think is very satisfying to watch slowly change as you edit it down. You can also tell if you have a random media floating away from the main video if this time stamp is longer than the main section. So for example, the main video is supposed to be here – which is 42 minutes, but if I scroll over here, I can see that I have a random one that’s floating. You can also type into your cursor[‘s timestamp] here, so if you ever just want to start from the beginning, you can just type in 0 [and hit enter]. You can also type in 0 [or other numbers] here.

If you look down below the time bar, you’ll see a bunch of buttons. This is a marker; it’s pretty nice for when you want to come back to a specific part for any reason. So say maybe the speaker referenced a website that I don’t have the link to yet but I’m going to soon, so rather than just waiting to edit until I have that information, I can just mark this and keep editing, and then as soon as I get that link, I can just click on the marker and add the link in. Just an example, but that’s one way you could use the marker for. This is just to mark specific sections. You can rewind, play, and forward here. You can also adjust the ratio of your settings here. So you can view it at 10%, or you could do it at 400. Maybe you want to make sure that things are exactly aligned, so maybe that’s why you want to zoom in this far. I typically just keep it at Fit until I need to look at specific details. And this button, you can actually export a frame, so if I click on this – I’m just going to say “example frame.” If you do have this checked,  then it’ll automatically import it into your project. So this is super helpful for when maybe someone is speaking but the slides kinda lagged, and so someone is talking about a slide but the audience can’t see it yet because it’s lagging. So you can just skip to the part where the slide is up, and then take a screenshot and import it, and then make it be extending over the audio where the speaker is talking about the [lacking] slide.

Timeline

OK, so let’s talk about the timeline. So in the timeline, you can forward and rewind. Pressing the space bar on your keyboard plays or pauses the video. You can also rewind or forward by a frame or two at a time by using the arrow keys on your keyboard. So if you know you’re really close to something that you want to edit, you can just slowly go through it, second by second. 

This bar right here lets you scroll through horizontally. This part will let you scroll through the visual part of your video, and this will let you scroll through the audio tracks vertically. To zoom in, you just grab this circle, scroll through like that. You can also zoom out, and you can zoom [in and] out on the vertical tracks as well. You can also hold alt [while dragging the circles in or out], and this will let you just scroll on the end that you are dragging. If you don’t hold alt, then it’ll scroll on both sides. And if you hold Alt while scrolling, it’ll zoom in without you having to click on these little circles. 

I personally like making the video tracks be the default size and making the sound tracks be a little bit taller to visualize the sound. This makes it easy to gradually raise or lower the volume, which I’ll show you in just a second. It also makes it easy to tell when a sentence containing a mistake starts and ends, which makes it easy to cut out. 

Okay, so to gradually raise or lower the volume: So, for example, maybe you have a music track right here, and you want it to gradually get a little bit louder at the beginning, and then at the end, you want it to gradually get softer. So to do that, you can add keyframes.

So go to the Effect Controls. Then on the Volume, which is under the Audio section, go to Level. It already has the animation  [feature] toggled on, which is indicated by the fact that it is blue. Then click on the circle to add a keyframe. Then scooch through a little bit more and add another keyframe. So say this is music, so this way it will get gradually louder. 

You can also just completely remove the sound by adding more keyframes, and then you can just click on the line and adjust it. This just makes it easy for when you want the visual part, but you don’t want the sound to be included. 

If you want to have a B-roll, which is a secondary form of media like pictures over your main visual, you can overlap your media like this. Tracks that have visual and audio connected to each other will be blue. Just visuals like images will be pink, and audio tracks by themselves will be green. You can also change the color by right clicking on your media, clicking Label, and then changing the color.

Tool List

In between the Project panel and Timeline panel, there’s a section of tools. Now that we have a media to play with, we can use them. 

The icon that looks like a normal mouse without the stem is the Selection Tool. This is for -- you guessed it -- selecting and moving your media around. It also can shorten or lengthen a media, if it allows. For example, if your video is 42 minutes and 43 seconds long like this one is, it can’t get longer than that. But it can get shorter. You can also lengthen pictures as long as you want. You can also drag to select multiple media like so or hold shift while selecting to select more as well. Either way will work fine.

The next button in the tool box looks like a dashed box with a block arrow coming out of it. It's called the Track Select Forward Tool. (Also with a short key of A) What this does is, if you select a media (or space in front of the media), it will select everything to the right of it, even on multiple tracks. So if I click right here, it’ll just select this one because this is the only media that’s occurring to the right of my cursor. If I click right here, it’ll select everything. So this comes in handy when you have a new media like a video clip or picture. This tool lets you easily select what you want to scoot down to make room for the new media to insert, which would be a pain to select manually otherwise – especially if you have already begun making edits before receiving the new media. 

The next tool we’ll talk about is the Razor Tool. It cuts your media up for you. So with your razor tool selected, you can click at the beginning and end of the part you want to remove, take your selection tool, and delete it. You can manually scoot everything back either by using the tool we just talked about or selecting it manually, and then moving it back. Or you can ripple delete by either selecting the space and pressing your keyboard’s delete button, or select the space, right click, and hit ripple delete. What it’ll do is delete the space or clip and make everything move down like a ripple.

The last tool here that I'll show you is the last one listed, the Type Tool. I'm sure you've seen this tool before, as it's pretty common in computer programs. You can add text with this. You click and drag on your video screen and can type what you want. This panel, the Effects and the Essential Graphics will automatically load up, and you can edit how the text looks on the screen. You can make it centered on the video, change its opacity, and change the font and spacing here just to name a few things you can do.

Effect Controls

As I mentioned earlier, this is where the controls to position clips live. Any additional controls you add will also be here. You can move it on the x axis by dragging here or clicking and directly typing in the number. You can do the same for the y axis too. You can scale your media to make it larger or smaller. For example, if you have the video feed of a speaker and also the video feed of their presentation, you might make the video feed smaller so the viewer can see the presentation better but still see the speaker's face. You can rotate it, change the opacity, all that jazz, here as well.

Important Shortcuts

Now that you have a basic understanding of what Premiere can do, I’ll go over some important shortcuts that will make your work go a lot faster without having to drag your mouse around or looking for what you want in the many menus. Most of these can be applied to a lot of other computer programs as well!

Command for Mac users and Control for everyone else + S – Save. It’s also Option for Mac users, and Alt for everyone else. 

Command/Control + Shift + S – Save as.
Command/Control + S – Save.
Command/Control + C – Copy. 
Command/Control + V – Paste. 
Command/Control + X – Cut. 
Command/Control + Z – Undo.
Command/Control + A – Select all. 
Command/Control + M – Export. 
Command/Control + D – adds a fade in/out transition if you’re selecting 2 or more clips.
Holding Alt/Option while dragging a media away will duplicate the media.

You might have noticed already, but a lot of tools and options will have shortcuts listed for you as well. For example, the basic tools I showed you earlier have shortcuts. So, if I hit T on my keyboard, you’ll see that the Type button is blue and selected now, which means I can add some text to the screen without having to manually click the button with my mouse.

You can also go to Edit -> Keyboard Shortcuts, or hit Control/Command + Alt/Option + K, and it’ll show you this full menu of shortcuts. It’s a little overwhelming at first, so feel free to just get acquainted with Premiere before diving into all the available shortcuts.

What we use Premiere for

Now that we have a basic understanding of what the different panels are and what they do, let’s get into what we use Premiere for.

The general types of edits we make are:
1. Cleaning up the beginning 
a. Which means taking out the beginning pause and any mistakes, so the edited video starts a couple sentences before the first speaker begins talking. Also, adding a cross fade transition. 
2.  Edits on the main, content portion of the video
a. Always: Taking out any mistakes or awkward parts 
i. like technical issues, speakers fumbling over their words, putting up a slide over the screen when the cameras lagged or when the event team lead is talking. 
ii. Uhm situation: We typically don’t take out “uhm’s” because it sounds more natural to keep them in, and it would also be way too time-consuming to take every ‘uhm’ out in every video. We will take some out if they’re distracting – i.e. the speaker says it a lot in a short amount of time, says it in between pauses, or says it in other distracting ways.

b. Occasionally: Adding in a video, music, images, or other media the speakers want – just pushing clips aside to make room for wherever the new media needs to be inserted.

c. Sometimes: making the duo screen with the speaker’s slides and camera bigger. Entails copying the clip, so you can crop each component separately and make them both as big as possible. We typically only do this when the slides are in an odd size or shape, so it didn’t fill up the screen as much.
3. Cleaning up the ending
a. taking out any information about future events, cleaning up the ending pauses, adding a cross fade transition, etc. 

Crop Tool

So, let’s say that I only want the video screen in this section; I don’t want the speaker’s camera on for this part. If I do have the slide, then I just insert that in. If I don’t have the original slide, I crop the video. 

The first step to crop is to make sure the video in the timeline is selected. Go to the right and under Effects, go to Video Effects, Transform, and either drag and drop the Crop feature to your clip or just simply double click Crop. 

In your video preview, you may have noticed that nothing changed. That's because you haven't actually changed the video yet. You just added a new effect control. Think of it like putting batteries into your remote, but you still have yet to press any buttons.

So go to your Effect Controls tab and scroll down, and sure enough, an option to crop your clip will be there. You can crop any side you want by dragging the number around or typing in the exact values. You can animate this too, and get super fancy with feathering the edges and adding masks and all that jazz.

Transitions

In the area below, Video Transitions, there’s a drop-down list of transitions. You can have a minimalist, less-distracting transition by selecting the clips you want, going under Dissolve and double-clicking Cross Dissolve, or simply Control/Command D. If you're making something for kids or something else that you want to make a bit more fun, you can use a different transition. It still follows the same way to be applied. Select all the clips you want to have the transition applied to and double click the transition to apply it.

I recommend that you re-watch all of the transitions to make sure nothing went awry. Sometimes video clips aren't long enough or in the right format to completely satisfy the transitions' built-in requirements. You might need to adjust the length of the transition by dragging it in the time line, adjusting the clips themselves, or just choosing a different transition.

Feel free to have fun with transitions on your own, but we typically use the Cross fade one since it’s less laggy and more professional. However, if you ever do need to use a more “fun” transition – like for a holiday video, I recommend adding transitions in at the end, as they can make Premiere laggy.

Light Adjustments and Sound adjustments

Hopefully, you will rarely have to make any light or sound adjustments, but sometimes, there’s background noise or it’s too dark. Sound is much harder to edit, and there might be nothing you can do. 

 But for your knowledge, there are some filters you can use to adjust the light, by going under Video Effects > Color Correction and double clicking any of the features here. As you can see, there’s many options to choose from and each one has settings you can adjust and play with later.   

For sound, there is a multitude of sound adjustments. You can take out the background noise, make the speaker sound a bit more muffled, etc. with all of these filters here. 

Inserting a shape

If you need to insert a shape, for example circle something on the screen, cover something up, or providing a background for text, you can do that directly in Premiere. If you want to have a gradient or anything similar, it would be better to do so in a program that’s more dedicated to graphic design work, such as Photoshop or Illustrator. But for a simple red circle or a white background, Premiere can do the trick.

Simply go to Graphics > New Layer and choose a rectangle or ellipse. Premiere also shows you the shortcuts here. I typically use rectangles (or squares) for backgrounds or to hide something like a phone number. And I use ellipses to circle things. 

Once you’ve clicked on it, you can change the dimensions by clicking and dragging the points. You can also change the position and scale here. If you want a different fill or stroke color than the default, you can go to Essential Graphics and adjust. Simply uncheck if you don’t want a fill or a stroke.

Exporting

Okay, so say I’m done editing now. I’ve got my title screen, the main presentation, some credits, a masterpiece. I’m ready to export and send it out into the world, on YouTube or some other website like that. 

Hit Command/Control + M, or go to File -> Export -> Media. Wait a second, and the Export Settings will pop up for you. Here’s where you can pick the format and preset. This helps with export time and quality, but they don’t really seem to help me make the export time faster. A good rule of thumb is that if your video is long, the export time probably won’t be faster than the runtime (or the length of your video). If you click on the output name, you can name your exported, final video and choose where to save it. You can choose to export just the video or the sound, which is handy if you just have one of these components and don’t want it to spend time exporting something that isn’t needed, like a black screen. There are more options that you can play with and learn about later, but for now, let’s make sure this says Fit, sequence in/out with the whole timeline selected or just have it as entire sequence, and then click export. 

Give it some time, and then it should say your video has successfully exported and it’ll be ready in your folder to be viewed and shared!


Problems and Solutions

Sometimes, we come across an issue or two, and this happens to the best of us. Whenever I come across a new error, I look it up and see if anyone’s had the same problem. Usually they do, and if it works for me, I write it down in case it happens again later. If it doesn’t work, then I keep experimenting. 

General fixes for any lagging or other weird issues are: to restart your computer, to restart (by closing and reopening) and/or update Premiere, and to close other programs that might be taking too much memory from your computer at the moment you are also trying to use Premiere. You can also go to Edit > Preferences > Media Cache and delete the media you don’t need anymore. I usually have it set to delete after a certain amount of days. You’ll still have the actual documents, but it just cleans up the storage and how smooth Premiere runs. After a couple weeks, if you don’t touch a video, you won’t again since we’ll be off to the next event. So it’s safe for it to delete after a month or two. Adobe programs typically works better with Macs, which is what I have for my personal laptop, but it works for me too on my work computer, which is a Dell.

These were the main issues I have had and what I either found from other people or myself that works to fix it. 

Importing Issues
Sometimes, you import a video that’s 28 minutes long actually, but in your Premiere file, it’ll be 20 for example.  Or it just won’t let you import at all.

There are a few things to do with or to the original video to hopefully help after the general fixes I just talked about. One is to redownload the video from Teams. That has fixed the specific 28 to 20 minutes issue that we’ve had before. Another is to Google a video converter online and convert your MP4 video to a MOV video file. Another that’s a little weird but sometimes works in desperate situations is to move it into a different folder or renaming it, then reimporting that new “version” of the video into Premiere. 

Box’s “0 GB” Issue
When you’re done editing a video, you need to export into the event’s Box folder. Then the event lead can access it, get the link, and share it with the people that they need to. It also allows you to grab the link to submit to Atlas for them to post to YouTube and to the UTD Research blog about it. 

Before you think, “great, I’m done, moving on,” go back to Box and make sure it says how big it is. If it says 0 GB, then it won’t work for the people you send it to, even if you can open it on your own computer and Premiere said it exported successfully. 

Don’t worry though. This is a Box issue, not Premiere, so you shouldn’t need to re-export. Just go to your folder on your computer, click your video, and drag it into the same folder on Box online. It should say that it’s uploading. When you return to check on it, it should be done and say how big it really is and will let you (and others that have permission) open it.

Media Pending

This next issue is typically more common with beginners. After you’re used to how Premiere works, you probably won’t get this error much. When I was a beginner, after I imported my clips, whenever I would come back after reorganizing or when I was returning to work the next day, some video clips in my Premiere file’s timeline would say “Media Pending” in a bunch of different languages in very bright, warning colors. This can be extremely frustrating, and it seems no matter what you do, you can’t get that screen to go away and load your actual video. Which causes the fear that you will have to start your whole project completely over.

If this happens to you, don’t panic. Probably nothing has gotten corrupted; Premiere most likely just lost the connection.

You might be wondering, “Well, what does that mean?” So, when you import something into your Premiere project (so right here), what you’re really telling Premiere is “Hey, here’s the file I want, and here’s where to find it.” When a file is imported into a project right here, Premiere will automatically link that media to the project. This is nice for memory, so Premiere relies on the computer’s file system and doesn’t completely reinvent a new library. If a file gets updated, this system also allows the file imported into Premiere to be automatically updated, so you don’t need to reimport the same file and have to re-edit it.

So if you’re editing a picture in Photoshop for example that’s in your Premiere project, you don’t have to worry about re-importing it into your Premiere, assuming it has the same name, location, and type as it did before.

That said, if that file or the folder it belongs in gets renamed or moved, the connection that Premiere automatically linked itself into is now broken, and it can’t find the file anymore on your computer. 

A few, easy fixes that helped me is to: 
1. Right click and hit “Link Media” and relocate the file for Premiere.
2. If that doesn’t work, go to Edit -> Preferences -> Media Cache. Click the Delete button next to remove media cache files. You can also say to delete them when they become older than x amount of days or when they get to be x amount of gigabytes. This just helps automatically clear up your Premiere and computer and help them both run faster and better, as I'.
3.  This next one don’t work as well for me, but they might for you: 
i. So, if you’re done editing this clip, right click and click “Render and replace.”

Unsupported format

Another really annoying error is when Premiere says that something is unsupported and can’t be imported into your project. This is probably referring to an extension issue. For some reason, I guess the way the original video was downloaded from an event or something, Premiere thinks that it can’t handle the mp4 video (that it usually can handle) anymore. 

My example: I’m just using an image, so I can guarantee that it’ll import pretty fast. And I just changed it to recreate the error.

To fix this, go to your folder/finder where the file is. Change the view so you can see the extensions. Select the video and hit Control/Command C and Control/Command V to copy paste it. This is just to make sure you have the original file, in case something goes (even more) wrong with this process. Right click your copied file and rename it. And change the .mp4 to .mov.  Click okay to the warning message that pops up, as we don’t need to worry about it since we still have the unaffected original. And here it is, letting me import it, great! 

Soundwaves not showing up

Sometimes, soundwaves don’t show up when you’re editing. This is incredibly annoying and makes editing a bit difficult, since you can’t clearly see where to cut something out. If your computer and Premiere is like mine, the ‘basic’ fixes are good ideas but still don’t work. What I found that works is make sure the video is unlinked from your sound. Then right click on your sound, and click Render and Replace. Then the sound waves should show up. They’ll be green now and will still be unlinked from your video. So if that bothers or inconveniences you, select both video and audio, right click, and click Link. You can also change the color by right clicking and hitting Label. You can label it with whatever color you’d like; I usually use Iris to make it go to the default color.

That concludes the “Premiere Problems and Solutions” section, as well as this tutorial and the tutorial series. Feel free to edit past events to practice editing and become more comfortable with Premiere. When you have an issue or need help with something that isn’t in this video, feel free to comment down below or watch tutorials on my personal channels. I hope this video helped you get started and feel more comfortable with Premiere, and I hope the tutorial series helped you with all of the topics discussed.

Thank you for watching, and have a good day! Bye!
